New version page

UCD EEC 180A - LAB 2- INTRODUCTION TO THE ALTERA DESIGN SYSTEM

Upgrade to remove ads
Upgrade to remove ads
Unformatted text preview:

UNIVERSITY OF CALIFORNIA, DAVIS Department of Electrical and Computer Engineering EEC180A DIGITAL SYSTEMS I Winter 2006 LAB 2: INTRODUCTION TO THE ALTERA DESIGN SYSTEM This lab provides an introduction to the Altera Quartus II design software. You will use the Altera tools to enter schematics and perform functional and timing simulations. This lab will be done as a self-paced tutorial. Preparation: Print this lab write-up and read it thoroughly before coming to lab. I. Simple Counter Design STARTING QUARTUS II The ECE Department has Altera's Quartus II software installed on the Linux and UNIX workstations. • Type setup quartus to configure your environment. (This only needs to be done once.) • Log out and log in, or open a new X-window • Type quartus & to start the program. • The first time you start the software, you will be prompted with a “Look and Feel” dialog box. Select the top option, “Quartus II”. • If prompted to automatically look for updates, select “No”. • You will then be prompted to create a new project. Click “Yes”. For this first lab, you only need to fill out Page 1/6. Choose a Project directory, something like eec180a/lab1/. Then choose a name for the design, like counter. Then click “Finish”. WINDOWS - Altera provides a free web-based version of Quartus II that you can download from: https://www.altera.com/support/software/download/altera_design/quartus_we/dnl-quartus_we.jsp Note that the file you must download is greater than 180 MB, so plan accordingly. USING COMMAND SHORTCUTS In addition to the pull-down menus, Altera provides many shortcuts for performing common tasks. There is a toolbar with buttons across the top of the screen. In addition, each separate tool has a unique set of buttons along the left side of the screen. Placing the cursor over a button will display the button's function at the lower-left corner of the window. Thus, you can quickly learn the function of each button.There are also keyboard shortcuts for commonly used commands. These are listed next to the commands in the pull-down menus. Many of these keyboard commands will be familiar, such as Ctrl-C and Ctrl-V for Copy and Paste, respectively. By clicking the right mouse button, you can bring up a pop-up menu for a third shortcut technique. CREATING A SCHEMATIC You can open a new schematic in at least three ways: • Type CTRL-n, or • Select New from the File menu , or • Click on the far-left icon on the toolbar Then select “Block Diagram/Schematic File” from the list, and click “OK”. Your new file will be called Block x.bdf, where x is some positive integer. You should give your schematic a name and save it in your own working directory. • Select Save As (File menu); Use the mouse to locate your working directory in the Directories box. Once you have located the directory, give your blank schematic a name. The .bdf extension will be added automatically. This directory will now become your default directory for this session of quartus. PLACING COMPONENTS To view the component libraries, • Double-click the left-mouse button (LMB) on the workspace, or Right-click on the schematic, and select Insert->Symbol. • On the left hand side, click the + box to view the libraries. • Double-click on “others”, and then “maxplus2”. You should see an alphabetical list of the symbols contained in the maxplus2 library. This library contains most of the standard 74-series components that are described in various data books. To place a component, you can type the symbol name in the Name dialog box or you can locate the specific symbol in one of the libraries and double-click the LMB on it. • Select the 74163 as the Symbol Name. Place the 74163 component in the center of your schematic page. You may want to use the Fit in Window (View menu->Zoom) option to locate the center of your schematic. Then you can change back to Normal Size (View menu).• Place an additional 74163 symbol on your schematic in order to build a simple 8-bit counter. One way to do this is to use the Copy and Paste options from the Edit menu, or the keyboard shortcuts.. MAKING CONNECTIONS There are two methods of drawing a net or bus between two pins. 1) If "Rubberbanding" is on, moving a device so that one pin touches another pin can make a connection. Once this occurs, the pins are connected and moving the devices apart will show a wire or bus. "Rubberbanding" can be turned on or off from the Options menu or using the icons on the left side of the screen. (By placing the cursor over each icon, you can display the function of each icon button at the bottom of the screen.) 2) If "Rubberbanding" is off, a wire must be drawn between the two pins. This is done by moving the cursor to the end of a pin until it changes from an arrow to a +. Dragging the mouse from one pin to another with the LMB pressed will draw a wire. • Wire the two 74163 components into an 8-bit counter circuit as shown in Figure 1. • Place vcc components on your schematic as needed to complete the circuit. You'll find vcc in the “primitives->other” library. • Place input and output components on the schematic as shown in Figure 1. You'll find input and output components in the “primitives->pin” library.MAKING CONNECTIONS BY NAME Although it isn't necessary for this counter circuit, you can also make connections by labeling wires with identical signal names. Wires with the same signal name are considered to be connected by the Altera software, as long as the wires are on the same level of hierarchy. Note that a signal name must be very close to the wire that it is naming, otherwise the Altera software will just interpret it as text rather than a valid net name. Thus if you move a signal name too far away from its net, it will cease to be a valid net name. You can check if a wire or bus is labeled by clicking on the wire or bus. If the text is highlighted along with the wire or bus, then it is a valid signal name. • Label the RCO output which connects to the ENT and ENP inputs of the other 74163 component as "rco1" as shown in Figure 1. We want to label this internal net so that we can view a trace of this signal during simulation. LABELING INPUTS AND OUTPUTS You must label input and output pins for your circuit to compile properly. • Label the input and output pins by double-clicking the


View Full Document
Download LAB 2- INTRODUCTION TO THE ALTERA DESIGN SYSTEM
Our administrator received your request to download this document. We will send you the file to your email shortly.
Loading Unlocking...
Login

Join to view LAB 2- INTRODUCTION TO THE ALTERA DESIGN SYSTEM and access 3M+ class-specific study document.

or
We will never post anything without your permission.
Don't have an account?
Sign Up

Join to view LAB 2- INTRODUCTION TO THE ALTERA DESIGN SYSTEM 2 2 and access 3M+ class-specific study document.

or

By creating an account you agree to our Privacy Policy and Terms Of Use

Already a member?